PDA

View Full Version : USB to PS/2 adapter: weird behaviour



VJ
21st March 2005, 02:46
Hello,

I noticed very weird behaviour with a USB -> PS/2 keyboard adapter. The packaging only lists a type number (UC 451N), which leads me to believe this is the adapter:
http://www.goodway.com.tw/en/product3.asp?listid=4&id=4&subid=10&pid=365&typeid=17
(but mine has a different colour, it was ordered along with a keyboard from the US).

The weird thing is: everything works as it should, apart from the key (on international layouts) that holds the < (normal), > (shift) and \ (right alt). I know that that key is not present on qwerty layouts, but the fact that this doesn't work isn't anywhere in the specs of the adapter. :mad: :(

I guess chances are that any USB->PS/2 adapter bought here in Belgium won't show this weird behaviour, but consider this a word of a warning (and a possible begin to start troubleshooting) if you plan to use a USB->PS/2 adapter. :)



Jörg

Kurt
21st March 2005, 03:47
have you tried with another keyboard?

VJ
21st March 2005, 04:18
Yep, I got it together with a new keyboard (and mailed a lot back and forth with their technical support), until I figured I could try the keyboard on the PS/2 directly: problem solved. And on my other keyboard connected via this adapter to USB, the <>\ key also doesn't work.

So it must be the adapter. :(


Jörg

VJ
21st March 2005, 05:29
Anyone has seen this?

Or are there adapters that might not show this weird behaviour (I'm looking at the iogear model).


Jörg