PDA

View Full Version : XP SP2 and DEP throws a wobbler



The PIT
12th August 2004, 10:53
One XP machine I've upgraded is having a fit with DEP. Doesn't matter how I set the options under system > performance it keeps flashing up warning and error messages about svhost having been blocked.

Sadly it doesn't tell me which programme is causing the problem. :(

ayoub_ibrahim
12th August 2004, 14:44
is this with an amd 64 cpu?

The PIT
12th August 2004, 23:58
Nope Intel.

The PIT
13th August 2004, 00:09
Looks like I can turn it of via the boot.ini.

Ms says you can do it vis system but I don't have the option if I remember correctly.

The error can be caused by programmes or drivers. My choice of culprits are

1) Creative
2) ATI
3) Nortons

ayoub_ibrahim
13th August 2004, 02:21
you should find it under system properties>advanced>performance>settings>data execution prevention.

The PIT
13th August 2004, 10:25
I know where it is but the option too turn it off isn't there as it should be.
So boot ini is the only other option.
oops I read the page wrong it's boot.ini only.

Well I done it and it works without a problem.

[GDI]Raptor
14th August 2004, 14:57
I thougt Intel didn't have DEP (NX-bit) in their processors except Itanium II

And that it would be included in the new F and J Pentium 4's and Xeons...

I use SP2 and DEP on my Athlon 64 with no problems...

Elie
14th August 2004, 15:10
How do you disable it in boot.ini?

Thanks,
Elie

Elie
14th August 2004, 15:12
Actually found this on the net...
-------------------------------------------------------
Try disabling DEP (Data Execution Protection) by editing your boot.ini file.

Remove the switch that says "/NoExecute=OptIn" (or =OptOut if you changed settings) and use the switch "/Execute"

Reboot.

HTH
--------------------------------------------

DGhost
15th August 2004, 13:27
Originally posted by [GDI]Raptor
I thougt Intel didn't have DEP (NX-bit) in their processors except Itanium II

And that it would be included in the new F and J Pentium 4's and Xeons...

I use SP2 and DEP on my Athlon 64 with no problems...

they were able to update the HAL to implement a software version of it for system files only...

Maggi
18th August 2004, 06:31
details on this very issue, directly from the horses mouth:
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2mempr.mspx

I had to alter my boot.ini to /noexecute=AlwaysOff in order to make the current HASP drivers working

btw, anybody got a clue why the feck MS marks the boot.ini as read-only, during installation of SP2 ???
:rolleyes:

The PIT
18th August 2004, 10:13
I think by default it's a read only hidden file if I recall correctly.

Maggi
19th August 2004, 10:35
I just cross checked and it is hidden in all cases, but neither Win2k nor WinXP SP1 had it marked as read-only, so that's a new security feature from WinXP SP2 ... :D

as if that would change a damned thing:rolleyes: