PDA

View Full Version : Blasted XP, all files read-only



Greebe
28th July 2004, 14:05
Wonder if anyone knows how to removed all files/folders marked as read-only... working on this system here that's all buggered up.

From earlier...

[15:11] Jammrock: Right-Click C:\ (Local C, whatever you called it)
[15:11] Jammrock: then...
[15:11] Jammrock: let me get exact instructions...
[15:11] Jammrock: R-C -> Properties
[15:11] Jammrock: Security tab
[15:12] Jammrock: make sure Administrators group is set to "Full COntrol" (check box)
[15:12] Jammrock: Click Advanced button
[15:12] Jammrock: Go to Owners tab
[15:13] Jammrock: Make sure the owner is "Administrators (<local Host>\Administrators)"
[15:13] Jammrock: go to Permissions tab
[15:14] Jammrock: make sure Administrators is set to Full Control there too
[15:14] Jammrock: check the box "Replace permission entries on all child objects..."
[15:14] Jammrock: click Apply
[15:14] Jammrock: wait...
[15:14] Jammrock: wait...
[15:14] Jammrock: wait...
[15:14] Jammrock: wait...
[15:14] Jammrock: Click OK
[15:15] Jammrock: Click Apply
[15:15] Jammrock: wait...
[15:15] Jammrock: wait...
[15:15] Jammrock: wait...
[15:15] Jammrock: Click OK
[15:15] Jammrock: reboot
[15:15] Jammrock: make sure that fixed it.


There is no security tab :(

Suggestions, ideas, brainfarts? ;)

gt40
28th July 2004, 14:25
I am assuming you tried the obvious-right click on folder, properties, uncheck the read only box, hit apply.

Wombat
28th July 2004, 14:26
What about doing it from a DOS prompt?
<B>attrib</B> might be the right tool here.

<code>N:\>attrib /?
Displays or changes file attributes.

ATTRIB [+R | -R] [+A | -A ] [+S | -S] [+H | -H] [path][filename]
[/S ]

+ Sets an attribute.
- Clears an attribute.
R Read-only file attribute.
A Archive file attribute.
S System file attribute.
H Hidden file attribute.
[drive:][path][filename]
Specifies a file or files for attrib to process.
/S Processes matching files in the current folder
and all subfolders.
/D Processes folders as well.

</code>

Greebe
28th July 2004, 14:40
the read only box is greyed out... tho it does allow you to uncheck it, once apply/ok is hit and reopen to verify it's back to read-only and greyed out

Greebe
28th July 2004, 14:43
Originally posted by Wombat
What about doing it from a DOS prompt?
<B>attrib</B> might be the right tool here.

<code>N:\>attrib /?
Displays or changes file attributes.

ATTRIB [+R | -R] [+A | -A ] [+S | -S] [+H | -H] [path][filename]
[/S ]

+ Sets an attribute.
- Clears an attribute.
R Read-only file attribute.
A Archive file attribute.
S System file attribute.
H Hidden file attribute.
[drive:][path][filename]
Specifies a file or files for attrib to process.
/S Processes matching files in the current folder
and all subfolders.
/D Processes folders as well.

</code>

and do this to most every file and folder?!

Greebe
28th July 2004, 14:44
and yes this is XP Pro

UtwigMU
28th July 2004, 14:46
Did you disable simple file sharing in Tools->Folder Options?

Greebe
28th July 2004, 14:55
I have that selected on this machine and don't have issue with it making most all files/folders read-only

az
28th July 2004, 15:01
attrib -r *.* /D /S

NOTE: This might not work for hidden files. Add -h to unhide them

AZ

Greebe
28th July 2004, 15:39
and do this to each new folder I create and then any new file either DL'd or moved to this machine?

az
28th July 2004, 15:41
Put it in your autoexec.bat ;)

No idea why it does that, sorry.

AZ

Chucky Cheese
28th July 2004, 15:41
...are we talking fat32 or ntfs ?? it was my understanding that the fat32 file system didn't have the security tab on the property sheet for hdds...am i wrong ??

cc

Greebe
28th July 2004, 15:42
yes this is a FAT32 volume

ZokesPro
28th July 2004, 16:24
Wow, now Greebe's the one asking for help, simply amazing this forum is! ;)

You could always boot into the console mode and run your attrib, pretty sure it'll work there as well.

agallag
28th July 2004, 16:42
So, attrib corrects existing files, but all new files are read-only? That's odd.

There shouldn't be a security tab if it's a fat32 volume, as there is no permissioning on fat filesystems. All local users have full control.

rylan
28th July 2004, 17:56
Hrm my Winxp has the same thing with all the files saying 'read only' in a greyed out box... however it never caused any problems and I can edit everything just fine.

High_Jumbllama
28th July 2004, 18:31
Originally posted by az

attrib -r *.* /D /S

NOTE: This might not work for hidden files. Add -h to unhide them

AZ

It will.

Attrib affect all files. The -h shouldn't hurt though.

Marshmallowman
28th July 2004, 18:42
if you have a folder and it contains files in it that are both readonly and writeable you get a greyed check. clicking on it go from clear to grey to checked which correspond to all writeable, leave as is, all read only..that is normal.

But greebes problem is he can't change the flag...

begin brainfart
I have never seen that before, do you have some read only device/ partition mounted in sub directory?
end of brainfart

Jammrock
28th July 2004, 19:17
Oh, you're using FAT32 ... that's why there's not Security tab. I've been using NTFS for so long I forget that people still use it ;)

You could always convert the partition to NTFS. You'd have more control over the files...

You could always boot to "Safe Mode with Command Prompt" and type in the following command (assuming you're on C:\):

ATTRIB -r C:*.* /s

In theory this will remove the read-only flag on every single and folder on C:. If it gives you errors or doesn't work right you might want to try C:\*.*.

One last option, if Safe Mode with Command Prompt doesn't work, you can install the Recovery Console (http://support.microsoft.com/default.aspx?scid=kb;EN-US;314058) and try it from there.

Those about all the options I can think of.

Jammrock

Indiana
29th July 2004, 02:10
I had this once, Win XP Pro Set all files to read-only because it thought there was an error in the filesystem - but didn't do an automatic Scandisk run.

Manually forcing the scandisk run to happen at the next boot time fixed the problem for me.
(This was with NTFS, however)

Jon P. Inghram
29th July 2004, 22:27
If simple file sharing is on in the folder options you won't see the security tab. Also, I see the same odd glitch with the read-only checkmark on my system, although it only effects folders, not files.

I wonder if it's a bug, if you click on the mark it cycles not through 2 settings (checked and unchecked,) but through 3, checked, greyed-out and checked, and unchecked.

Jon P. Inghram
29th July 2004, 22:34
Ah, it's by design actually,

http://support.microsoft.com/default.aspx?scid=kb;en-us;326549&Product=winsvr2003

Jon P. Inghram
30th July 2004, 13:29
Oh, and one last thing, if you tried the little trick in the first post about applying the security settings to all files it may mess up the permissions of the Prefetch folder contents, causing it to not work properly (defrag program no longer knew which files were the "boot" files, i.e. those needing to to be moved to the front to boot up quicker.) Deleting the folder fixed it by causing XP to start a new one with fresh contents that had the proper permissions.