PDA

View Full Version : Stupid webhosting question



GT98
3rd June 2004, 08:09
I signed up for 1and1.com for my web hosting, but every time I try to goto my webpage via its domain name, it keeps asking me for my user name and password. Did I miss a setting some where or something so you can access it?

az
3rd June 2004, 09:02
Do you have any content there yet?

AZ

GT98
3rd June 2004, 15:37
yeah I uploaded a gallery to a folder off the root using Front page. When I point my broswer either to the webpage or to that directory it asks for a password.

Tjalfe
3rd June 2004, 16:07
if you have frontpage installed, try playing with the site permissions
Tools>Server>Site Administration Home
Especially check Anonymous access :)

Edit: Typo

GT98
3rd June 2004, 16:40
Originally posted by tjalfe
if you have frontpage installed, try playing with the site permissions
Tools>Server>Site Administration Home
Especially check Anonymous access :)

Edit: Typo

Ok anonymous access is enabled

my web address is

shermannetworks.net

I either get a 404 or 401 error.

Tjalfe
3rd June 2004, 17:21
hmm.. I get, what I am sure you are getting too:


You are not authorized to view this page
You do not have permission to view this directory or page using the credentials that you supplied.
--------------------------------------------------------------------------------

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page.
Click the Refresh button to try again with different credentials.
HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 401.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Authentication, Access Control, and About Custom Error Messages.


if anonymous access is enabled, then perhaps now is a good time to chat with your webhosting company tech support :(

GNEP
3rd June 2004, 23:44
Are you sure that the gallery's index page is called something that the server is looking for as the default index page in a directory - usually index.html or index.htm or default.html or default.htm or even .php/.asp/.jsp etc - it may be that the .html versions are enabled on the server but your gallery is assuming .htm is OK... and hence with no index file it is denying access as (presumably) the "directory view" is disallowed by default as it should be.

Check what the allowed default index filenames are in the webhosts help pages.

G

dbdg
4th June 2004, 04:46
A web hosts I had a few years ago required the default index page to be caled home.htm, try that as well.

There isn't a htaccess file in the directory is there?

Edit: or the equivilant for a windows server.

SuRGV
4th June 2004, 20:52
I'm using 1and1 and index.html works fine.