PDA

View Full Version : UT2k3 Demo and Hardware 3d sound



SteveC
25th September 2002, 03:29
Hi all,

Anyone get the hardware 3d sound setting (or the +EAX one) to work with a SBLive! in the UT2k3 demo? When I select it, I only get music and no sound effects... (Win2k)

Gurm
25th September 2002, 05:58
Works fine with my Audigy. Might I suggest you try the UDA drivers?

- Gurm

SteveC
25th September 2002, 06:02
UDA?

Actually, could it be that I'm only using the digital out from the Live and the hardware surround only works when using the front/rear analogue channels?

Lucid
25th September 2002, 06:19
Works here with Live! and digital out.. (Win98SE, though)

I'm still using old v4 drivers as well.. :)

thop
25th September 2002, 06:26
btw. can anyone explain me why hardware accelerated sounds makes my FPS go down a bit?

Pace
25th September 2002, 07:33
Does software sound not get done by the sound card? I'm using basic WDM SBLive drivers just now, as provided my Win2k, and MP3 decoding has 0% CPU utilisation. I don't know about games though. Maybe there's a game which has No Sound, Software and Hardware modes to test if enabling 'Software' slows the game down at all, and then 'Hardware'.

P.

thop
25th September 2002, 07:43
pace: do some benchmarks with UT2003, HardwareSound makes me loose about 5FPS.

Dogbert
25th September 2002, 08:18
I think it's because the CPU does some voice pre-rendering (wave tracing) before sending the results to the soundcard.

K6-III
25th September 2002, 08:19
I thought Wave Tracing was only for A3D 2.0....or perhaps EAX3...

Tempest
25th September 2002, 08:20
They have quite a nice UT2003 FAQ at http://users.pandora.be/byeclan/UT2003FAQ/index2.htm

Among other things, it says
Set your audio setting to Software 3d. Hardware 3d and EAX seems to cause some performance hit. This can help you gain around 10 fps.

Dogbert
25th September 2002, 08:24
Originally posted by K6-III
I thought Wave Tracing was only for A3D 2.0....or perhaps EAX3...

Seems you're right :)

SteveC
25th September 2002, 08:26
Originally posted by Tempest
They have quite a nice UT2003 FAQ at http://users.pandora.be/byeclan/UT2003FAQ/index2.htm

Among other things, it says

I won't worry then :)

XHotKolaX
25th September 2002, 12:53
Software sound also only does 22050Hz sound. Hardware does the normal 44100Hz.

Prolly the performance hit reason there.

I only know because my soundcard monitors samples outputed. My reciever says so too=P