PDA

View Full Version : GLQuake on Matrox cards



dZeus
1st May 2002, 02:54
you might have noticed that GLQuake performs poorly by default on Matrox G-series cards, and with some 'image corruption' going on in several places. Fortunately, most of these problems can be fixed:

Poor performance:
- type 'r_dynamic 0' in the console or add it to your autoexec.cfg, which disabled dynamic lighting. Appearantly dynamic lighting is either not or poorly accelerated in the Matrox OpenGL ICD. After disabling dynamic lighting you can enable other features which previously slowed down the system to a crawl, like 'gl_flashblend 0' (see glnotes.txt that's included with GLQuake for more details).

Statusbar corruption:
- when starting GLQuake, pass these command line parameters:
"GLQuake.exe -width x -conwidth (x-1)", where x is the horizontal resolution you want to run GLQuake at (4:3 aspect ratio will be preserved, so no -height parameter is needed). For example "GLQuake.exe -width 800 -conwidth 799" will run GLQuake at 800x600 and will fix the status bar corruption.

Brightness issue (game is too dark) in Win2k/NT/XP
- download idGamma to tweak the colour pallette in glquake to your needs. The default 'Matrox' entry did the job on my config just fine. Be sure to enter the full path to your Quake\ID1 directory, otherwise it won't work. You can download it from here: http://www.g256.com/idgamma

Unresolved issues:
-You may/will see some texture corruption going on, on floors and walls mostly.
- r_mirroralpha won't work on the ICD (yet? ever?).