PDA

View Full Version : Insanely strange problem with Win2K Matrox drivers



excession
17th March 2001, 23:43
I'm posting this because it had me stumped, and it is unbelievable.

System: Athlon 1200Mhz (not o/c)
Asus A7V with 1006bios
256MB memory
G400MAX video card
Windows 2000 Pro SP1



I downloaded the latest Matrox drivers for Windows 2000 (win2k551), uninstalled my 533 drivers, installed the new drivers and immediately found that I could not start ANY 3d games. Games like Quake3 Arena, Soldier of Fortune and Hardwar would all just freak out and throw me back to the desktop.

Unreal Tournament would ALWAYS die with 'kmode exception not handled', no matter how I tried to run it.

No amount of BIOS tweaking or DirectX 8 reinstall would fix the problem.

Ok -- so I reverted.

533 drivers (what I had been using well for months) -- the SAME problem was evident, none of my 3D game would work.

Went to Matrox forums, and read somewhere thay they recommended the latest VIA 429 4in1 patch for VIA chipsets ...

So, uninstalled drivers.
Reboot
Install VIA 4in1 version 429
Reboot
Install latest 551 Matrox drivers
Try Quake3, no go, all 3d games fail.

Download latest BIOS for Matrox G400
Upgrade bios on video card

Still no fix.

Get Matrox TWEAK utility, try all combinations, no fix.

Download WHQL certified drivers (514) and go through the install procedure, no go.

Get the MATROX uninstall utility (exactly same dialogs as Windows 2000 uninstall), and reinstall WHQL drivers. No go.

All normal video works fine, only 3D games are affected.

Tried Unreal Tournament in DEBUG mode, telling it to reset its settings -- get the KMODE exception not handled blue-screen death

Then a strange thing -- after the reboot, I tried UT again and it worked. So did Quake3, so did Soldier of Fortune. This was with the 514 drivers. But I hadn't changed anything, merely tried UT, had it crash the system, and then try it again.

Ok, so I then uninstalled the WHQL drivers, and RE INSTALLED the newest 551 beta, and WHAMMO, no more 3D games. Tried Unreal Tournament debug mode, crash reboot, tried again crash, reboot, again, crash reboot. Pretty solid bad.

Revert to 533 which I've been running for more than a month. Try UT, crash, reboot, then -magic- everything works again.

Now that's MONDO STRANGE.

I have spent easily 20 hours researching the problem and trying combinations to get my 3D games working again, and this WEIRDNESS is just completely beyond my understanding.

I hope anyone else who has problems with Windows 2000 551 drivers and games not working can get hold of this information and use it to revert back AND get their system working again.

Thanks for reading.

Inray
18th March 2001, 01:59
Hi,
I don't know about games (as i don't play) but it's true that latest Win2k drivers (551) have many problems. I had stability issues using them on more than ten G400max equipped computers we use in our company, though i had never such problems with Matrox.
I found 2D/3D CAD programs had stability problems, desktop delays, IE (5.5) crashes and many others.
Matrox confirmed some of these issues and then i uninstalled 5.51 and revert to 5.33.

Now everything works fine again.
So to avoid problems stay agay from 5.51

PeTe
18th March 2001, 02:26
Yeah, same problems here, after installing the latest drivers the pic went crazy in normal 2d, w2k still worked on the backround... boot to vga-mode, uninstall, reinstall the old drivers and not a single problem since.

I have to say that these latest OFFICIAL drivers are WORSE than ANY beta driver that i have EVER used. =) Well, better luck next time matrox.

Pete

Nuno
18th March 2001, 03:42
I have to disagree. For me, these drivers fixed a big problem with 5.3x, agp was disabled is most athlon systems.

I donīt think the are less stable than previous win2k drivers. All games run fine and I even ran a 6-7 hour 3dmark2001 loop to check system stability at agp 2x.

Heed
18th March 2001, 05:01
Make sure that you have dualhead disabled. In win2k, 3d will not function if dualhead is enabled.

Heed.

DentyCracker
18th March 2001, 05:24
hehe. I run games without a problem with 5.51 and Duron 700@950 Abit KT7 256 MB AGP4X (no hacks) oh and I forgot, DualHead is disabled

[This message has been edited by DentyCracker (edited 18 March 2001).]

excession
18th March 2001, 05:57
Dual Head is disabled.

I have tried everything short of a complete system rebuild (which would be more than a bit painful). Will send problem report in to Matrox as soon as their damned forums open for business (grrr).

Prior to installing 551 the system was extremely stable, worked very well indeed for all games (Quake3Arena, Soldier of Fortune, Unreal Tournament, Hardwar, etc), now (after reverting to the previously good 533 drivers) it just refuses to cooperate at all, and NO error messages in the OpenGL games, just booted straight back to desktop.

Unreal Tournament (Direct X) will consistently crash with some longwinded Kmode Exception Not Handled error.

I am completely stumped.

excession
18th March 2001, 07:53
BOY! Do I feel stupid now!

I FOUND the problem.

IOLO Macro Magic, a keyboard enhancement/macro player.

I got this tool last week, and it is useful for sending stuff to certain windows.

Disabling Macro Magic FIXED the OpenGL gaming problem entirely.

So it wasn't the 551 drivers, or any other matrox drivers.

I just hadn't played any QUAKE in the last week or so, and only -tried- to after I'd upgraded video drivers, otherwise I would have known to suspect a newly added program.

SHEESH

Moral of story -- CHECK, CHECK, and CHECK AGAIN that you haven't installed something 'new' on your system, BEFORE blaming the drivers you just installed http://forums.murc.ws/ubb/wink.gif

Sorry for wasting people's time.

Gurm
18th March 2001, 08:04
No, no no!

It's not a waste of time.

The 5.51 drivers have COMPATIBILITY issues.

It _is_ probably your macro program, but it is _also_ the drivers. Even on clean installs, some people (such as myself) have MAJOR problems with these drivers.

OpenGL games boot you back to the desktop, nVmark2001 kmodes the hal.dll halfway through, and just general whackiness.

If uninstalling the keyboard program works for you, great. But some of us have a system incompatibility which cannot currently be cured.

So it's not a waste of anyone's time to try to figure it out.

- Gurm

------------------
Listen up, you primitive screwheads! See this? This is my BOOMSTICK! Etc. etc.

Perseus
18th March 2001, 16:34
My experience follows:

My OS is Win2K with sp1 installed. I've been using the 5.04-5.51 drivers, upgrading fairly regularly along the way. I only had to go back to a previous driver once early on due to discovering the frame rates would crawl when using Quake2 laser (broken dynamic lighting display code? forgot which 5.xx driver version it was).

I always run the usual benchmarks, Quake 2&3 and Indy3D for Opengl, and MadOnion 3DMark2K and FreeSpace2 space-sim for Direct3D testing with each driver upgrade to test for stability. I couldn't use 32 bit Zbuffer in 32 bit display mode with the earlier drivers. It was too buggy, so I've ALWAYS used 16 bit Zbuffer. Also, huge chunks of frames in all the 3DMark2K tests were being skipped for some unknown reason to me. This really irked me to no end as I could not for the life of me determine why it was doing that.

Now with 5.51, it was totally locking up on me at the end of the Indy3D MCAD OpenGL video benchmark. Limiting the AGP to 2X helped solve that problem.

Yesterday, while testing Image Quality in Indy3D, I noticed the drivers were using 16-bit color texture map and improperly sorting translucent polygons. I read the documentation, and it mentioned that 16bit Zbuffer was the cause for the sorting problem. I said to myself, "What the heck, let's enable 32 bit Zbuffer and see what happens!" Behold, it cured the sort problem and I noticed it hardly ever skips any frames in the 3DMark2K tests anymore. All my tests passed with flying colors, Hallelujah! It appears though that the hardware or software is limited to using 16-bit or less color texel storage in OpenGL at least.

Moral: Try enabling 32 bit Zbuffer. You'll sacrifice some performance, but I prefer stability over performance anyday. I haven't tested AGP 4X again yet. I'm using v5.51 with DualHead support installed and disabled.

</Rant>
When will Matrox release a fully optimized and reliable OpenGL ICD. Nvidia has a far superior OpenGL driver than the Matrox one. Regardless of how fast and cool the G550/G800 will be, I will NEVER buy it unless they release much better OpenGL drivers. Read the bottom of this page: http://www.x-plane.com/SYSREQ/v5ibm.html
I want to buy this software, but am reluctant to because of this warning.
</rant>

Regards,

Perseus

excession
18th March 2001, 16:36
Well, after a further reboot, my weird 3D problems are back http://forums.murc.ws/ubb/frown.gif (as in no games will work).

I am stumped.

I will try Matrox support forum and see if those guys can help.

I ran Matrox Tweak utility to change OPENGL to 'optimised for speed' and now nothing works. I will try to change it back, but I hold little hope of a stable system.

SteveC
18th March 2001, 18:18
Hi Perseus!

If that's the same 'X-plane' as I think it is, then you'd might like to know that I know someone who used to run it on a G400, but got a good few problems (in performance and visually) and just bought a Geforce 2 GTS becuase of the problems.

Admittedly, we (my local computer shop where I work) installed the latest (publically available) drivers and most of the problems went away (apart from it was still quite slow compared to the Geforces)

------------------
Cheers,
Steve

"Life is what we make of it, yet most of us just fake"