PDA

View Full Version : OpenGL vsync



jImbEam
3rd January 1997, 06:45
Thanks, I will give those a try when I get home today.

jImbEam

jImbEam
12th May 2000, 07:52
I was wondering if there is a way to turn on vsync for OpenGL apps like Q3? I used the PD 5 Registry Hacks, file to enable vsync, but I did not seem to change anything for OpenGL. Is that reg key only for DX apps?

I don't really like the tearing I get in Q3 so any help will be appreaciated.

Athlon 650 W/ K7M
G400Max
Win98 w/ 5.52 Drivers
TurboGL 1.30

Thanks,
jImbEam

Nuno
12th May 2000, 08:42
Try entering in the console r_swapInterval "1"

Rik
12th May 2000, 10:19
I think it will only work if you use the FULL Opengl ICD from a 5.5x version of Powerdesk (rather than a TurboGL), as only this contains the OpenGL extension for Swapinterval. You can check this in the Quake III OpenGL driver information screen, where it lists all the available OpenGL extensions supported by your video driver.

MURCer
15th May 2000, 11:42
up

jImbEam
15th May 2000, 21:28
Well I tryed the r_swapinterval "1" thing, but it still looked like it was tearing, even with PD 5.52.

I looked at the supported gl extensions in Q3 and this is what was supported that looked like they might be vsync:
TurboGL:
GL_WIN_swap_hint

PD ICD:
GL_WIN_swap_hint
WGL_EXT_swap_control
CL_KTX_buffer_region

Now I am not sure if any of those are vsync. Anyone know what the extension is? Thanks.

jImbEam

Rik
16th May 2000, 10:26
Hello again. 'WGL_EXT_swap_control' is indeed the correct extension for V-Sync, but there is also something in the registry which relates to this. It can be found at the following location:
[HKEY_LOCAL_MACHINE\Software\Matrox\PowerDesk\Curre nt Settings]
where there is a line called "User3D.SwapIntervalExtEnable" which I think should be set to "1" (Not sure if the default is 1 or 0). There's some other stuff here as well, but I'm clueless as to what it does.
I've noticed that when you do finally get V-Sync on in QIII the effect compromises smoothness and creates a feeling of choppiness (maybe the OpenGL ICD doesn't support Triple-buffering?). I prefer to leave it off and use a monitor refresh rate of 100hz or more, which makes the tearing not so bad.
Anyway, when you're running around in QIII like your arse is on fire you tend not to notice tearing walls.

jImbEam
16th May 2000, 13:37
Ahh, so the TurboGL dosen't support vsync being turned off.

Last night I tried 800x600@100Hz and it was very smooth with very-very little tearing with the TurboGL. But I am not sure that I want to go back to 800x600. Maybe I will try the 100MHz refresh rate at 1024x768 and see how it is. Thanks.

jImbEam