PDA

View Full Version : TurboGL and Half-life decal problem



Johnny Ray
8th October 1999, 22:49
Hi,

Was really enjoying Half-life with my G400Max and PowerDesk 5.25 drivers on my PIII 500 MHz. Absolutely no problems. Just had to try the TurboGL and 5.30 drivers, and now I'm having a decal problem. They flicker, fragment, dissappear, etc. The decals display fine with D3D and 5.30 drivers. My Half-life autoexec.cfg file is essential the one Kruzin has posted previously:

gl_ztrick "1"
gl_dither "1"
gl_polyoffset "4"
gl_lightholes "1"
gl_keeptjunctions "1"
r_decals "1"
r_drawviewmodel "1"
r_shadows "0"
cl_himodels "1"
gl_texturemode "GL_LINEAR_MIPMAP_LINEAR"
brightness "2.5"
gamma "3.0"
gl_playermip "0"
gl_picmip "0"
gl_round_down "0"
gl_texsort "1"
gl_overbright "1"
gl_palette_tex "1"
r_decals "400"
scr_conspeed "8000.00"
r_mmx "1" //added 9/18/99 JRC
s_a3d "1" //added 9/18/99 JRC
joystick "0" //added 9/18/99 JRC
s_eax "0" //added 9/18/99 JRC

I've tried different gl_polyoffset values, all leading to the same results.

f:\2fort0000.bmp

I'm not sure what to try next. The TurboGL manager says all is fine. Thanks for any suggestions.

John

Wombat
8th October 1999, 23:11
I would first try turning off the z-trick. Then try playing with texsort.

Good luck,
Wombat

Kruzin
8th October 1999, 23:24
I would not change gl_texsort.
gl_ztrick may or may not do anything.
The one I would mess with is gl_polyoffset. Try anything from -1 to 12. You can use any value, including decimals. (but you already tried that)

Also, try enabling 32bit zbuffer in the advanced powerdesk options if it's not already...

[This message has been edited by Kruzin (edited 10-09-1999).]

IceStorm
8th October 1999, 23:26
Looks great here. Figured out how to get V2 and G400 MAX to coexist, too. 1152x864 is perceptually smoother than 1024x768, don't know why (and no, 1024x768 isn't burping - fixed that one).

I can get all my specs if necessary. I did turn off ztrick, I turned on paletted textures (had them on from the G400 Tweak util), and I left shadows of? on? r_shadows 0, whatever.

Anywho, got more testing to do.

Buckaroo99
9th October 1999, 00:23
I have damage images (blood, burn marks, etc.) flicker and are now missing entirely with 5.30. I also lost the fog effect in water you see in the Well map. Tried 32 z. Any suggestions would be appreciated.

Buckaroo99
9th October 1999, 00:53
Disregard previous post. Polyoffset worked for me.

troop
9th October 1999, 05:18
Hl still needs a bit of work--a ceilinglight which is solid on a V2 comes'n goes now depending on the players position . Mostly it is half there.Colours are better though and speed is fine .
Textures in Q3 need work too. Max textures are unplayable here .

------------------
In Harm's Way

Kruzin
9th October 1999, 06:15
Troop-
Did you turn on 32bit z-buffer?
I had a simialr problem with OGL, where certain lights and sighns at a distance would "flicker" in and out of view. 32bit zbuf fixed it right up...

troop
9th October 1999, 09:42
Kruzin ( "for a bruzin" me dad used to say ).
Yes I use 32bit zb.The light is in crossfire,
main courtyard, hallway leading to the 2 rooms under the main second floor , at the end of the hallway , there's a light on the ceiling. Turn right there to get to the platform that goes to the second floor. See it ?


------------------
In Harm's Way

Kruzin
9th October 1999, 10:12
No, I don't see it....but I'm also only using the regular ICD...no P3/K7 here...

Wombat
9th October 1999, 11:51
Even with a 32-bit z-buffer, the light should still flicker if z-trick is true. Try turning that off.

-Wombat

Johnny Ray
9th October 1999, 19:51
Thanks for the suggestions. I've tried them all, but nothing improved the situation. I did do a complete uninstall of PD 5.30, and re-installed 5.25. The decal problem is still there, but doesn't seem as bad (no change in autoexec.cfg). Uninstalled 5.25 and went back to 5.30 (heh...if the problem's there with both, I might as well get the extra FPS!). Now, no decals at all. The autoexec.cfg does have r_decals "1", so they should be on.

Any other ideas?

Thanks,

John

Kruzin
10th October 1999, 13:46
r_decals "1" means ONE decal will be displayed, until another one is created.

try r_decal "400" or something...

Johnny Ray
10th October 1999, 14:44
Thanks Kruzin...

I thought r_decals meant decals on ("1")or off ("0"), and mp_decals was the number of decals displayed. I'll give it a shot.

John

Scout255
11th October 1999, 14:19
Originally thAts how you would enable/disable decals. however, in newer releases, they put a number on them instead of disableing/enableing them.

billko
11th October 1999, 16:39
Check for duplicate entries in your config.cfg. Settings in config.cfg override those in the autoexec.cfg.

To help your problem, set:

gl_polyoffset "2"

in your autoexec.cfg. Remember the rule above about autoexec.cfg and config.cfg!

Happy Barney-Blasting... http://forums.murc.ws/ubb/wink.gif

Bill

PS - I had the SAME PROBLEM as yourself, and it was because even though I had

gl_polyoffset "2"

in my autoexec.cfg, I had

gl_polyoffset ".001" in my config.cfg (a left-over from my G200 days, I think). I rem'd the line out in my config.cfg and everything was fine.

------------------
People call me a computer god; I remind them that I am merely a minor deity...

Johnny Ray
11th October 1999, 21:40
Hey Billko....

Thanks much. That was the ticket. Sure enough, gl_polyoffset was set to -0.001 in config.cfg. Change to 4 and bingo. Nice to know the priority of those cfg files.

Thanks all, really appreciate your comments.

John

P.S. Now if I could only see the water in Heavy Gear II at 32 bit color......